All systems operational

Resolved
Inability to login

Started
November 06, 2023 at 6:02 PM
Status
Resolved after about 1 hour

Impact

Major outage
Affected
Otterize Cloud (app.otterize.com)
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this incident.